abicare logo home page
Coronavirus (COVID-19) updates

NHS Covid-19 app: All YOU Need to Know!

As we’re sure you’re all aware, the new NHS Covid-19 app has launched, enabling everyone to be part of the track and trace system.

Rather alarmingly, cases have started to rise again and we are all encouraged to continue to do what we can to help stop the spread of the virus, particularly as the threat alert level has been raised to Level 4. Government guidelines are starting to change again because of this elevated threat level, which will undoubtedly affect many businesses. 

If we all pull together by adhering to the following advice then hopefully we can stop another full lockdown being put into place. As the Autumn and Winter months draw in, inevitably the amount of cold and flu viruses will increase, which causes the immune system to be affected, and can make you more susceptible to Covid-19. Therefore, please remember to:

  • Wash hands
  • Cover face
  • Make space

You can find out more at the Government website: https://www.gov.uk/coronavirus

Why use the NHS Covid-19 app?

One major way that we can help is to download the NHS Covid-19 app. On the app you can ‘check in’ when you enter an establishment that has a QR code for you to scan. You can also find out the area risk level where you live and you can also check your symptoms and enter test results if you’ve had a test for Covid-19.

It’s quick and easy to download and set up. However, following the step-by-step guides below does provide useful information to make the process as easy as possible.

  • I have an iPhone, how do I download the app? *

https://covid19.nhs.uk/iphone-download-guide.html

  • I have an Android phone, how do I download the app?

https://covid19.nhs.uk/android-download-guide.html

To find out more about the app and why it is so beneficial, please visit https://covid19.nhs.uk/

* Please be aware that if you are using an iPhone handset that is older than the iPhone 6S, you will receive an error message saying that iOS 13.5 or later is required to run the app.